Instalacja TP1.0 i SMF 2.0 RC4

Zaczęty przez woti, Listopad 03, 2010, 20:29:54 pm

« poprzedni - następny »

0 użytkowników i 1 Gość przegląda ten wątek.

woti

Listopad 03, 2010, 20:29:54 pm Ostatnia edycja: Listopad 03, 2010, 21:36:16 pm by Nolt
Aktualizacja: No, i jest pasztecik - w prosty sposób TP10RC1 nie chce się instalować z SMF2RC4 :(
Natomiast galeria Aeva Media "weszła" bez problemu.

Edycja:
Jeszcze o problemie TP+smfRC4: na testowym localhost miałem ładnie zaktualizowany z smf1... do smfRC3 + TP1 + Media Gallery. Po uaktualnieniu do smfRC4 "wyrzuciło" wszystkie moje poprawki (np. dodane i przestawione w subs.php zakładki), pozwoliło na aktualizację Media Gallery (po uprzedniej deinstalacji) do wersji 1,4, ale NIE zostawiło "łączności" z TP ani nie pozwoliło TP ponownie zainstalować. Podaje komunikat, ze wersja niekompatybilna.... Próbowałem z paczką .zip a także wgrywać różnie TP wprost do stosownego katalogu i tam "odpalić" - podaje, że brak SSI.php albo inne takie banialuki. Co zrobić? Jakieś sugestie?

Nolt

Tak wiem że jest problem z instalacja, zgłosiłem to na oficjalnym forum, w sumie można to obejść ale nie wiadomo czy będzie to kompatybilne i zmieni kod poprawnie. Zobaczymy co odpiszą i dam znać ;)
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Nolt

Jak na razie jedyną metodą do zainstalowania TP (tak jak podejrzewałem) jest albo emulacja wersji RC3 (Pakiety>Zaawansowane>Emulacja wersji, zmieniamy tam RC4 na RC3) lub edycja paczki w następujący sposób.

Otwieramy paczkę i edytujemy plik package-info.xml dodając pod
<upgrade for="2.0 RC3" from="1.098, 1.099, 1.100">
<redirect url="">Upgraded!</redirect>
                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />
                <require-dir name="common/Themes" destination="$boarddir" />
<require-dir name="SMF2RC2/Sources" destination="$boarddir" />
                <require-dir name="common/tp-downloads" destination="$boarddir" />
                <require-dir name="common/tp-images" destination="$boarddir" />
<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />
                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF2.0 RC3</readme>
               <modification format="boardmod" type="file">SMF2RC3/tinyportal200rc3b.mod</modification>
               <database>SMF2RC3/tp_upgrade.php</database>
        </upgrade>


tak zmieniony kod oraz zapisujemy plik:
<install for="2.0 RC4">
<redirect url="">Installed!</redirect>
                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />
                <require-dir name="common/Themes" destination="$boarddir" />
<require-dir name="SMF2RC2/Sources" destination="$boarddir" />
                <require-dir name="common/tp-downloads" destination="$boarddir" />
                <require-dir name="common/tp-images" destination="$boarddir" />
<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />
                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF2.0 RC4</readme>
               <modification format="boardmod" type="file">SMF2RC4/tinyportal200rc4.mod</modification>
               <database>SMF2RC4/tp_upgrade.php</database>
        </install>
<uninstall for="2.0 RC4">
                <modification format="boardmod" type="file" reverse="true">SMF2RC4/tinyportal200rc4.mod</modification>
        </uninstall>
       <upgrade for="2.0 RC4" from="1.098, 1.099, 1.100">
<redirect url="">Upgraded!</redirect>
                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />
                <require-dir name="common/Themes" destination="$boarddir" />
<require-dir name="SMF2RC2/Sources" destination="$boarddir" />
                <require-dir name="common/tp-downloads" destination="$boarddir" />
                <require-dir name="common/tp-images" destination="$boarddir" />
<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />
                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF2.0 RC4</readme>
               <modification format="boardmod" type="file">SMF2RC4/tinyportal200rc4b.mod</modification>
               <database>SMF2RC4/tp_upgrade.php</database>
        </upgrade>


Kolejną rzeczą jaką musimy zrobić zawartość folderu SMF2RC3 do folderu SMF2RC4 i zmienić nazwy plików
tinyportal200rc3.mod oraz tinyportal200rc3b.mod
na
tinyportal200rc4.mod i tinyportal200rc4b.mod
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

woti

Haha - nie zajrzałem tu i trochę żal. Ale dzięki temu znalazłem równoległy sposób na obejście problem, także grzebiąc w pliku package-info, ale bez żadnych zmian w pozostałych plikach. Poniżej CAŁY ten plik - wystarczy podmienić zawartość.
RC<?xml version="1.0"?>

<!DOCTYPE package-info SYSTEM "http://www.simplemachines.org/xml/package-info">

<package-info xmlns="http://www.simplemachines.org/xml/package-info" xmlns:smf="http://www.simplemachines.org/">

        <name>TinyPortal</name>

        <id>bloc:tinyportal</id>

        <type>modification</type>

        <version>1.101</version>

        <install for="1.0.6-1.0.99">

                <readme type="inline">

TinyPortal will no longer support SMF 1.0x versions, as it now depends on many features not present in SMF 1.0.x. We urge you to upgrade your forum to v1.1 if you like to install TP.

</readme>

       </install>

        <install for="1.1, 1.1.1-1.1.99">

<redirect url="">Installed!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF1.1.x</readme>

<modification format="boardmod" type="file">SMF1/tinyportal1090.mod</modification>

               <code>SMF1/tp_install.php</code>

       </install>

<uninstall for="1.1, 1.1.1-1.1.99">

                <modification format="boardmod" type="file" reverse="true">SMF1/tinyportal1090.mod</modification>

        </uninstall>

       <install for="2.0 RC2">

<redirect url="">Installed!</redirect>

                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF2RC2/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />

                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF2.0 RC2</readme>

               <modification format="boardmod" type="file">SMF2RC2/tinyportal200rc2.mod</modification>

               <database>SMF2RC2/tp_upgrade.php</database>

        </install>

<uninstall for="2.0 RC2">

                <modification format="boardmod" type="file" reverse="true">SMF2RC2/tinyportal200rc2.mod</modification>

        </uninstall>

       <upgrade for="2.0 RC2" from="1.098, 1.099, 1.100">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF2RC2/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF2.0 RC2</readme>

               <modification format="boardmod" type="file">SMF2RC2/tinyportal200rc2b.mod</modification>

               <database>SMF2RC2/tp_upgrade.php</database>

        </upgrade>



   <install for="2.0 RC4">

<redirect url="">Installed!</redirect>

                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF2RC2/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />

                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF2.0 RC4</readme>

               <modification format="boardmod" type="file">SMF2RC3/tinyportal200rc3.mod</modification>

               <database>SMF2RC3/tp_upgrade.php</database>

        </install>

<uninstall for="2.0 RC4">

                <modification format="boardmod" type="file" reverse="true">SMF2RC3/tinyportal200rc3.mod</modification>

        </uninstall>

       <upgrade for="2.0 RC4" from="1.098, 1.099, 1.100">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF2RC2/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF2RC2/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF2RC2/tp-files" destination="$boarddir" />

                <readme type="inline">Installing TinyPortal v1.0 RC1 for SMF2.0 RC4</readme>

               <modification format="boardmod" type="file">SMF2RC3/tinyportal200rc3b.mod</modification>

               <database>SMF2RC3/tp_upgrade.php</database>

        </upgrade>





<upgrade from="0.96, 0.97, 0.98, 0.981, 0.982, 0.983">

                <readme type="inline">Please un-install TinyPortal 0.6-0.9.x before installing the new TinyPortal 1.0. You will NOT loose any data, and everything will work as before. After un-installing(removing the modifications to SMF files only) you can then re-install TP v1.0 and it will pick and use the old data. Note that TP no longer need to use custom TP themes, it will use SMF themes just fine..but you WILL need to add the extra "forum" button/tab to the theme.</readme>

</upgrade>

        <upgrade for="1.0.5-1.0.99">

               <readme type="inline">

TinyPortal will no longer support SMF 1.0x versions, as it now depends on many features not present in SMF 1.0.x. We urge you to upgrade your forum to v1.1 if you like to install v1.0 of TP.

</readme>

       </upgrade>



<upgrade for="1.1, 1.1.1-1.1.99" from="1.00, 1.01">

<redirect url="">Upgraded!</redirect>

<require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                 <modification format="boardmod" type="file">SMF1/tinyportal1010-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.02">

<redirect url="">Upgraded!</redirect>

<require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                 <modification format="boardmod" type="file">SMF1/tinyportal1020-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.03, 1.04, 1.041, 1.048">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                 <modification format="boardmod" type="file">SMF1/tinyportal1048-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.049, 1.050, 1.051, 1.052, 1.053, 1.054, 1.0.55, 1.0.56">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                <modification format="boardmod" type="file">SMF1/tinyportal1050-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.0.57,1.058, 1.059, 1.060, 1.061, 1.070, 1.071, 1.072, 1.073, 1.074">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                <modification format="boardmod" type="file">SMF1/tinyportal1056-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.075">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                <modification format="boardmod" type="file">SMF1/tinyportal1075-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.076, 1.077, 1.0.78, 1.079, 1.080">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                <modification format="boardmod" type="file">SMF1/tinyportal1080-1090.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

        <upgrade for="1.1, 1.1.1-1.1.99" from="1.081, 1.082, 1.083, 1.084, 1.085, 1.090, 1.091, 1.092, 1.093, 1.094, 1.095, 1.098, 1.099, 1.100">

<redirect url="">Upgraded!</redirect>

                <require-dir name="SMF1/Themes" destination="$boarddir" />

                <require-dir name="common/Themes" destination="$boarddir" />

<require-dir name="SMF1/Sources" destination="$boarddir" />

                <require-dir name="common/tp-downloads" destination="$boarddir" />

                <require-dir name="common/tp-images" destination="$boarddir" />

<require-dir name="SMF1/tp-files" destination="$boarddir" />

                <readme type="inline">Upgrading TinyPortal v1.0 RC1 for SMF1.1.x</readme>

                <modification format="boardmod" type="file">SMF1/tinyportal11b.mod</modification>

                <code>SMF1/tp_install.php</code>

       </upgrade>

   </package-info>

woti

Listopad 08, 2010, 14:54:34 pm #4 Ostatnia edycja: Listopad 08, 2010, 14:57:37 pm by woti
Aktualizacja - 08,11,2010:
Żeby nie było, że sam sobie odpisuję => ale nie modyfikuję powyższego, bo rzecz nie o zmianach w paczce... a uwaga wydaje się ważna: otóż w czasie instalowania TPitd. "na SMF4" pokazał się komunikat związany z "porażką" modyfikacji plików:
CytujZnajdż w pliku ./Sources/Security.php:
// Require a user who is logged in. (not a guest.)
function is_not_guest($message = '')
{
global $user_info, $txt, $context;

(Notabene w moim pliku znalazłem dodatkowo na końcu ...$scripturl)
I poniżej wklej:
// Require a user who is logged in. (not a guest.) function is_not_guest($message = '')
{ global $user_info, $txt, $context;
// TinyPortal TPortal_init();


Niezaleznie od tego, czy powyższe wykonałem przed zatwierdzeniem instalacji moda, czy już po - zawsze okazywało się, że forum NIE WIDAĆ! Niewykonanie tego polecenia - jest OK.
Reasumując: jedną z przyczyn kłopotów z instalacją TP1+smfRC4 może być istnienie powyższego "dodatku".

Donera

Interesujący poradnik. Przetestuję sobie.

Polska Pomoc Simple Machines Forum TinyPortal Ubuntu Linux

TinyPortal © 2005-2019