Wizzi - www.wizzi.pl

Polskie wsparcie TinyPortal => Problemy, porady => Wątek zaczęty przez: kammillobyk w Listopad 15, 2008, 16:16:17 pm

Tytuł: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 16:16:17 pm
Witam, mam problem z napisaniem artykułu w TinyPortal, mianowicie gdy napisze artykuł na stronie główniej pojawia się coś takiego: 

Wystąpił błąd!
Artyku� jest nieaktywny, nie zosta� zatwierdzony lub po prostu nie istnieje.

Myślę że wszystko zrobiłem poprawnie, w zatwierdzeniach nie mam nic.
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 15, 2008, 21:28:28 pm
Jaka wersja TP i czy stworzyłeś kategorię dla artykułów?
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 21:56:18 pm
Tak stworzyłem kategorie ... Wersja TP v.1.0.6 beta 2

Chciałem również zapytać jak można pozbyć się znaków typu "Ĺ� "  ??
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 15, 2008, 22:16:55 pm
Czy przy pisaniu artykułu zapisałeś go w danej kategorii? (podczas pisania jest taka opcja). A poza tym to trochę dziwne :D Testowałem teraz świeżo na localhost i artykuł się pojawia normalnie :o
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 22:17:59 pm
Tak ... przypisałem go do danej kategorii ... też jestem tym zaskoczony ... ponieważ wszystko powinno działać normalnie ...

W panelu-> Raport błędów  pisze również coś takiego

8: Undefined offset: 1
Plik: /smftest/Sources/TPSubs.php
Linia: 77

Może jest to z czymś powiązane ?




Oraz tak jak pisałem ... istnieje możliwość pozbycia się tego typu znaków "Ĺ� " ??  Wgrana polonizacja TP to TP106_beta2_polish_utf-8 .
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 15, 2008, 22:40:52 pm
Znaki to drugi problem, SMF masz tez w wersji UTF oraz całą bazę utf-8_general_ci?

Co do błędu totalnie nie mam pojęcia, polecam udanie się na oficjalną stronę i opisanie błędu, może autor pomoże.
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 22:43:19 pm
Na SMF mam wgraną wersje polonizacji 1.1RC lecz nie wiem czy też jest wgrana w wersji UTF jednak tam nie mam takich znaków.

A co do tego błędu artykułów jest jakiś sposób ?
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 15, 2008, 22:52:21 pm
Jeśli masz kodowanie SMF ISO (możesz to sprawdzić w obsłudze forum>zmień kodowanie bazy na UTF (ale nie rób tego, skrypt pokaże Ci jakiego kodowania używasz) wtedy kodowanie TP musi być takie same. Co do błędu podejrzewam że właśnie problem leży po stronie samego SMF. TP 1.0.6 był pisany z myślą SMF 1.1.x stable a RC to bardzo stara wersja i temu mogą pojawiać się błędy.
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 22:54:33 pm
Jak się tego pozbyć ?? Wgrać polonizacje TP ISO ? Może to też być wina błędów pisania artykułów ?
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 15, 2008, 23:01:30 pm
Kodowanie nie powinno powodować błędów pisania artykułów, ale wersja SMF jak najbardziej. Co polecam to pobranie ze strony www.simplemachines.org 1.1.7_large_update, zaktualizowanie forum i spróbowanie wtedy.

PS w ogóle polecałbym aktualizacje, wersja która posiadasz to wersja bardzo stara posiadająca masę błędów.
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 23:09:08 pm
Mam wersje SMF 1.1.7 z polonizacja 1.1RC oraz TP 1.0.6_beta2 ... wiec nie wiem za bardzo co mam zaktualizować ....
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 15, 2008, 23:24:12 pm
:D :D sorry, nie doczytałem hehe. Spróbuj więc ze spolszczeniem jeśli się nie uda, spróbuj na www.tinyportal.net
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: kammillobyk w Listopad 15, 2008, 23:29:31 pm
Czyli jednak nie jesteś mi w stanie pomóc z tymi artykułami ... Wgrałem spolszczenie TP ISO ... i zniknął problem ze znakami .... Teraz tylko problem artykułów na których jednak najbardziej mi zależy ....
Tytuł: Odp: Problem z Artykułami TP
Wiadomość wysłana przez: Nolt w Listopad 17, 2008, 12:25:38 pm
Niestety nie wiem co może być powodem.