Mangos najnowszy z dnia (14.02.10) problem z bazami.

Zaczęty przez Nerus, Luty 14, 2010, 17:00:31 pm

« poprzedni - następny »

0 użytkowników i 1 Gość przegląda ten wątek.

Nerus

Witam.
Posiadam Linux-a Debian-a wczoraj instalowałem, dzisiaj skompilowałem mangosa pod system.
Użyłem bazy najnowszej i zaktualizowałem ją "UDB_0.11.6_Core_8734_SD2_1480.sql" do "387_updatepack_mangos.sql".
Dodatkowo wgrałem "characters.sql", "create_database_sd2.sql", "realmd.sql" z linku https://unifieddb.svn.sourceforge.net/svnroot/unifieddb/trunk/Full_DB/ForCleanInstallOnly/.

Przy uruchomieniu realmu:

./mangos-realmd
MaNGOS/0.16.0 (* * Revision 9372 - *) for Linux_x64 (little-endian) [realm-daemon]
<Ctrl-C> to stop.

Using configuration file /opt/mangos/etc/realmd.conf.
Database: 127.0.0.1;3306;root;hasło;realmd
MySQL client library: 5.0.51a
MySQL server ver: 5.0.51a-24+lenny2+spu1
SQL: SELECT required_9010_01_realmd_realmlist FROM realmd_db_version LIMIT 1
query ERROR: Unknown column 'required_9010_01_realmd_realmlist' in 'field list'
Table `realmd_db_version` have field `required_7546_02_realmd_uptime` but expected `required_9010_01_realmd_realmlist`! Not all sql updates applied?


Oraz przy uruchomieniu world:

./mangos-worldd
MaNGOS/0.16.0 (* * Revision 9372 - *) for Linux_x64 (little-endian) [world-daemon]
<Ctrl-C> to stop.


MM   MM         MM   MM  MMMMM   MMMM   MMMMM
MM   MM         MM   MM MMM MMM MM  MM MMM MMM
MMM MMM         MMM  MM MMM MMM MM  MM MMM
MM M MM         MMMM MM MMM     MM  MM  MMM
MM M MM  MMMMM  MM MMMM MMM     MM  MM   MMM
MM M MM M   MMM MM  MMM MMMMMMM MM  MM    MMM
MM   MM     MMM MM   MM MM  MMM MM  MM     MMM
MM   MM MMMMMMM MM   MM MMM MMM MM  MM MMM MMM
MM   MM MM  MMM MM   MM  MMMMMM  MMMM   MMMMM
        MM  MMM http://getmangos.com
        MMMMMM


Using configuration file /opt/mangos/etc/mangosd.conf.
OpenSSL 0.9.8k 25 Mar 2009 (Library: OpenSSL 0.9.8g 19 Oct 2007)
WARNING: Outdated version of OpenSSL lib. Logins to server may not work!
WARNING: Minimal required version [OpenSSL 0.9.8k]
Using ACE: 5.6.6
World Database: 127.0.0.1;3306;root;hasło;mangos
Connected to MySQL database at 127.0.0.1
MySQL client library: 5.0.51a
MySQL server ver: 5.0.51a-24+lenny2+spu1
AUTOCOMMIT SUCCESSFULLY SET TO 1
SQL: SELECT required_9366_02_mangos_spell_proc_event FROM db_version LIMIT 1
query ERROR: Unknown column 'required_9366_02_mangos_spell_proc_event' in 'field list'
Table `db_version` have field `required_9310_01_mangos_spell_elixir` but expected `required_9366_02_mangos_spell_proc_event`! Not all sql updates applied?


Jakią/jakie bazy mam wgrać ?
Pozdrawiam.

Nolt

Z błędu wynika że jest coś nie tak w bazie reamld, spróbuj więc wyczyścić całą bazę realmd i wgrać plik który utworzył się w paczce mangosa po komilacji.
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Nerus

Luty 14, 2010, 18:17:52 pm #2 Ostatnia edycja: Luty 14, 2010, 20:33:24 pm by Nerus
Dobra jeszcze jedna sprawa związana z bazami danych.
Jakie są potrzebne podstawowe do poprawnego działania serwera i jakie są dodatkowe.

Skompilowałem jeszcze raz.
ok. realmd już mi śmiga, problem jest dalej z wordem:


./mangos-worldd
MaNGOS/0.16.0 (* * Revision 9383 - *) for Linux_x64 (little-endian) [world-daemon]
<Ctrl-C> to stop.


MM   MM         MM   MM  MMMMM   MMMM   MMMMM
MM   MM         MM   MM MMM MMM MM  MM MMM MMM
MMM MMM         MMM  MM MMM MMM MM  MM MMM
MM M MM         MMMM MM MMM     MM  MM  MMM
MM M MM  MMMMM  MM MMMM MMM     MM  MM   MMM
MM M MM M   MMM MM  MMM MMMMMMM MM  MM    MMM
MM   MM     MMM MM   MM MM  MMM MM  MM     MMM
MM   MM MMMMMMM MM   MM MMM MMM MM  MM MMM MMM
MM   MM MM  MMM MM   MM  MMMMMM  MMMM   MMMMM
        MM  MMM http://getmangos.com
        MMMMMM


Using configuration file /opt/mangos/etc/mangosd.conf.
OpenSSL 0.9.8k 25 Mar 2009 (Library: OpenSSL 0.9.8g 19 Oct 2007)
WARNING: Outdated version of OpenSSL lib. Logins to server may not work!
WARNING: Minimal required version [OpenSSL 0.9.8k]
Using ACE: 5.6.6
World Database: 127.0.0.1;3306;root;hasło;mangos
Connected to MySQL database at 127.0.0.1
MySQL client library: 5.0.51a
MySQL server ver: 5.0.51a-24+lenny2+spu1
AUTOCOMMIT SUCCESSFULLY SET TO 1
SQL: SELECT required_9382_01_mangos_command FROM db_version LIMIT 1
query ERROR: Unknown column 'required_9382_01_mangos_command' in 'field list'
Table `db_version` have field `required_9310_01_mangos_spell_elixir` but expected `required_9382_01_mangos_command`! Not all sql updates applied?

Nolt

W katalogu sql skompilowanej binarki są aktualizacje bazy danych poszukaj plików takich jakie pokazuje błąd i wgraj je.
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Nerus

Luty 15, 2010, 18:25:57 pm #4 Ostatnia edycja: Luty 15, 2010, 20:49:44 pm by Nerus
Dobra zaraz zwariuje, jaką bazę mam wgrać, przy standardowych po kompilacji i wgraniu bazy mangosa do wersji 9385 wszystko śmigała ale bez postaci, npc itd.
Jak wgrywałem bazę UDB to mi wywala znowu ten sam błąd co przed wgraniem 9385.
Po wgraniu patcha 9385 na UDB wywala mi błąd że potrzebny jest update niższy niż ten który chce wgrać i tak w kółko.
Jak to jest z tymi bazami ?

Nolt

Masz skompilowany MaNGOS 9385 natomiast baza obsługuje 9310 i taką masz obecnie. Tak więc aby wszystko działało musisz zaktualizować swoją bazę wgrywając ją w następujący sposób:
UDB>aktualizacje od UDB>aktualizacje z folderu sql skompilowanej binarki czyli pliki od 9310 do 9385.
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW