Autor Wątek: Download manager TP  (Przeczytany 5842 razy)

0 użytkowników i 1 Gość przegląda ten wątek.

Offline woti

  • Użytkownik
  • ***
  • Wiadomości: 53
  • Pomógł: 4
  • Po mnie? Byle nie tylko debet...
    • Szczecińska Galeria Internetowa
Zachowuje się dziwnie, bo częściowo jest - a częściowo nie.
Na przykład można dodać plik, ale nie widać, ze dodano, dopiero po dłuższych kombinacjach.... Okazuje się, ze jest w stosownym katalogu.
Próba kliknięcia Tiny Portal (admin) >  Moduły > Menedżer plików (z opcją "Włączony") = komunikat:
 Wrong value type sent to the database. Integer expected. (week)
Tensam komunikat, gdy z menu głównego kliknąć: TinyPortal > Download

Dodałem MP blok na stronie głównej - ale nie pokazuje żadnego pliku do pobrania. Widać to teraz:  http://www.ruchpalikota.szczecin.pl
Brak też możliwości pobrania pliku! Można go sobie co najwyżej edytować...

Czy coś ekstra trzeba grzebać w ustawieniach?
 Wygląda na to, że w sql stosowne rubryki są, ale puste  - choć wpis w tp_dlmanager dot. wpisania pliku *.pdf tam istnieje - natomiast tp_dldata jest "blady" i nie daje się otworzyć.

I jeszcze, gdy w opcjach ustawień TP kliknąć: Moduły to Shoutbox wyśwetla się grubo, a Manager Plików blado (niezależnie, czy jest włączony, czy wyłączony).
***********
Aktualizacja - 2012,01,07, g. 14,34: Po włączeniu konserwacji systemu i bazy danych trochę się poprawiło, tzn. "sciemniał" MP. Nadal jednak wyświetla się komunikat: Wrong value type sent to the database. Integer expected. (week) po wybraniu "Download" z głównego menu, oraz inne wyżej opisane.
Udało mi się natomiast ustawić blok download w panelu bocznym - ale nie można pobrać = komunikat: Wrong value type sent to the database. Integer expected. (week)
-- Przy próbie wpisania tagów globalnych wywala komunikat:
Błąd bazy danych:
Plik: .../Sources/TPortalAdmin.php
Linia: 2735
************
Aktualizacja z 03,02,2012: Dzisiaj dodało niemal poprawnie, ale plik wysłałem via FTP, zaś później nazwę pliku musiałem wpisać do SQL "z palca"! Podobnie musiałem wpisać wielkość pliku (tak, jakby podawało z błędem rzędu wielkości, np 4 KB zamiast poprawnie 40 KB).
« Ostatnia zmiana: Luty 03, 2012, 14:38:13 pm przez woti »

Offline Nolt

  • Administrator
  • *****
  • Wiadomości: 956
  • Pomógł: 69
  • Płeć: Mężczyzna
    • Wizzi
W pliku TPdlmanager.php:

znajdź

$week = date("W",$now);
$year = date("Y",$now);


Zmień na:

$week = (int) date("W",$now);
$year = (int) date("Y",$now);

Kody występują w kilku miejscach (chyba w 4 jeśli dobrze pamiętam).
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Offline woti

  • Użytkownik
  • ***
  • Wiadomości: 53
  • Pomógł: 4
  • Po mnie? Byle nie tylko debet...
    • Szczecińska Galeria Internetowa
Serdeczne dzięki. Podziałało :)

Offline woti

  • Użytkownik
  • ***
  • Wiadomości: 53
  • Pomógł: 4
  • Po mnie? Byle nie tylko debet...
    • Szczecińska Galeria Internetowa
Jest jeszcze jeden "byczek" - po kliknięciu na menu TP>Download nad nagłówkiem "Nowe pliki" widać zbędny znacznik: </b>. Gdzie tego nadmiaru szukać?

Offline Nolt

  • Administrator
  • *****
  • Wiadomości: 956
  • Pomógł: 69
  • Płeć: Mężczyzna
    • Wizzi
Gdzieś u siebie błąd masz, wgraj nowe tłumaczenie.
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Offline woti

  • Użytkownik
  • ***
  • Wiadomości: 53
  • Pomógł: 4
  • Po mnie? Byle nie tylko debet...
    • Szczecińska Galeria Internetowa
Oczywiście wczoraj wgrałem nowe paczki. Psiakość - wczoraj działało, a dzisiaj nie! Mam chmod'y na 777...
Dzisiaj wysyłam pdf ( a jest w dopuszczonych plikach) - podaje komunikat:
"The server encountered an internal error or misconfiguration and was unable to complete your request.
Potem że ma się ze sobą skontaktować... I dalej:
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
Żadne logi błędów się nie pojawiają!
Spróbowałem nawet "upgrade_tp.php" - zameldowało, że OK. I nic. Dodam, że instalowałem z "poradnikiem" smf dla tego moda.
Aha w pełnym bocznym menu admin TP NIE widać nic o "downloadzie".
Nie działa też możliwość dodawania plików przez FTP (z poziomu admina dodawania).
W sekcji "Opcje" - w edytorze HTML nadal widać "byka" </br> - nie ma go w Wysiwyg

Próba wysłania pustego pliku - z powodzeniem, ale nic nie tworzy.
Wrzucenie pliku bezpośrednio ftp do katalogu "tp_downloads" - nic nie daje.
Dopiero ponowne "przypisanie" pliku (edycja itd.) - skutek OK.

Ostatecznie odinstalowałem stary TP, wrzuciłem.zip z nowym (chmod 777+"jako program") - skrypt jakoby poprawnie zainstalował nową wersję TP. Nie pokazało żadnych błędów. A wpisać i tak nie mogę, stare byczki tez widać. Opadam z sił! Pomocy!!! Cierpliwośći!!!
Można tyle, co i wcześniej :(

Offline Nolt

  • Administrator
  • *****
  • Wiadomości: 956
  • Pomógł: 69
  • Płeć: Mężczyzna
    • Wizzi
Nie wiem co może być powodem, może problem nie leży po stronie TP tylko samego forum?
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Offline woti

  • Użytkownik
  • ***
  • Wiadomości: 53
  • Pomógł: 4
  • Po mnie? Byle nie tylko debet...
    • Szczecińska Galeria Internetowa
Jest jeszcze jeden szkopuł, a może nawet dwa ze sobą powiązane:
Zarejestrowany użytkownik, a na pewno admin - widzi blok "Downloads", natomiast goście NIE widzą.
I nie mogę w żadnych ustawieniach zezwoleń tego prawidłowo ustawić. Tzn. w ustawieniach forum smf oraz w "Zezwolenia" TP w ogóle brak opcji dla download. W "Wyświetlanie bloków" TP ustawiłem na tak > widać blok bez zawartości (widok dla gości), a po ustawieniu na nie - znika cały blok.

Offline Nolt

  • Administrator
  • *****
  • Wiadomości: 956
  • Pomógł: 69
  • Płeć: Mężczyzna
    • Wizzi
Panele i Bloki>Wyświetlanie bloków tu możesz ustawić. Podobnie gdy edytujesz blok z działem Download Wybierz grupę użytkowników którzy będą mogli widzieć blok. też musi być wszystko ustawione.

Zauważ iż u mnie dział Download jest widoczny także dla Gości
PMIĘTAJ O KORZYSTANIU Z OPCJI SZUKAJ
nie udzielam pomocy poza forum i na PW

Offline woti

  • Użytkownik
  • ***
  • Wiadomości: 53
  • Pomógł: 4
  • Po mnie? Byle nie tylko debet...
    • Szczecińska Galeria Internetowa
OK - co udało sie ddać - widać :)
Ale mam nadal problemy z dodawaniem plików. Tzn. dodaje plik o zawartości 0kb i nawet "reczne" wgranie przez ftp tego nie poprawia.

 

Polska Pomoc Simple Machines Forum TinyPortal Ubuntu Linux